Back to overview
Degraded

Client Portal Slow Loads

May 14 at 11:01am CST
Affected services
Billing Portal

Resolved
May 18 at 05:11pm CST

We have Resolved This matter.

Created
May 14 at 11:01am CST

We’re currently investigating reports from some users experiencing slow loading times on the client portal. The issue is related to increased latency in one of our internal services. Our team is working to resolve it as quickly as possible, and performance should return to normal shortly.